[Linux] Electrisheep only displays a white square

I've checked out the latest version of flam3 and electricsheep from the repositories and build them following the instructions in Linux Client Instructions.

When I run electricsheep it only displays a white square divided in half by gray line. Here is a screenshot: http://img37.imageshack.us/img37/5139/electricsheepwhitesquar.png

Other client functions are operational as it is downloading video files to the conten/mpeg directory and accepts the keyboard command to neg vote and delete a sheep (down arrow key).

On the other hand electricsheep-preferences isn't saving modifications. For instance I've tried to enable "Debugging log" but when I re-open electricsheep-preferences it is disabled. This module isn't writing the xml in .electricsheep directory as usual.

 

I'm using Ubuntu 10.10 and had electricsheep partially working when using the version in Ubuntu's repositories. Though it is quite old (2.7b11) and some time ago stopped downloading new sheep, thus I would like to update.

Can anybody give me an help?

white square :(

me the same...

all white :)

 

I am using wine with linux. The only way to watch something is the Settings.exe. Thats ok. But i see only the white square???

 

What to do?

 

I uploaded one sheep in the ./wine....content folder. Is one sheep is an .avi file?

 

Dont know

Love it :D

I seem to have the same

I seem to have the same problem here, I also only see a white square within a black screen, just like in this screenshot. I built the svn revision 124 on a Debian unstable.

I didn't build flam3 manually, the one in the Debian repositories seems to be the latest already (3.0.1-2.1). I also didn't do a "make install", I'm running "Client/electricsheep" from a local directory.

The older electricsheep version from the Debian repo (2.7~b12+svn20091224-1.1) runs fine though.

http://electricsheep.org/node/51#comment-4736 says that it's supposed to have been fixed. Am I doing something wrong?

 

EDIT: Ok, the missing "make install" really was the issue for me. For anyone else who doesn't like plain "make install"s, the following fixed this issue for me:

"make clean; ./configure --prefix=$EMPTY_DIR_TO_INSTALL_INTO; sudo make install". And then running "$EMPTY_DIR_TO_INSTALL_INTO/bin/electricsheep" for instance (replace $EMPTY_DIR_TO_INSTALL_INTO with your prefered, empty directory). Then you can undo the "make install" at any time simply by removing $EMPTY_DIR_TO_INSTALL_INTO again.

thanks for the report.  alas

thanks for the report.  alas i have never seen anything like that.

 

This is happening to me as

This is happening to me as well.  When I install it using apt-get, it won't go fullscreen.  I get letterboxes on the left and right with text in yellow on the left-hand side (output from execution?).  When I compile from source, I get a white box in the middle and nothing happens.


User login