Design Your Own Sheep

While the screensaver is running, you can use the up (or down) arrow key to vote for the sheep you like (or not), and so influence the evolution of the flock.

Furthermore, you can design your own sheep and post them into the gene pool.  If your sheep are popular, they will interbreed with the rest of the flock and produce children.  By mutating and crossing the genomes, variations of your sheep will appear and themselves evolve.

To design your on sheep, Windows users can run Fr0st or Apophysis. Mac users run Oxidizer.  Linux users have their choice of Apophysis under Wine or Qosmic, a native Qt application.  There's also a portable Java version for all platforms.

There's a Sheep Edition of Apophysis that has exactly the right variations you'll need.

For more information, see the Fr0st blog and the Sheep Design Tips on the wiki.

After you've got a hang of the software and are ready to share, join the genetic design email list and ask for the password for connecting to the server.

I can't find the Java version

I can't find the Java version to download. Anyone have a link for it? Thank you.

looks like that one died, try

looks like that one died, try this:

Thanks a lot. Could you

Thanks a lot. Could you provide a guide on how to upload the sheep?


Thanks, but...

Thanks, but I'm a little confused when it comes to uploading my sheep. Can you explain a little more in-depth? Thanks!

you have to join that email

you have to join that email list & then ask there.



Sheep edition?

I just ran the Sheep Edition of Apophysis, and the only difference I can spot is the variations. Is that supposed to be it?



Make a .avi flame?

I want to do a screensaver for my electric sheep but all I can do is a flame... How can I render a movie screensaver for electric sheep?


You can use Fr0st:

First, run the script "" under sheep_tools.

Next, render all the resulting flames.

Then you can use software like VirtualDub to smash all the pictures into an AVI movie.

Sheep Edition of Apophysis

The Link above for the Sheep Edition od Apophysis appears to be a dead link is there a new URL available?

thanks for the report.  the

thanks for the report.  the link is fixed.


thanks you admin

Fr0st on mac

I have been wanting to get fr0st on my mac for a while so when I saw this post I was very exited. I followed the link and found these instructions:

To run it unzip, open a terminal and "cd" into the folder, then run "./".

I have unziped the file, and I know what terminal is but not how to use it. Can someone give me exact step-by-step instructions on how to do this?


Open the Terminal application

Open the Terminal application and to the newly opened terminal window drag the "" file from your unzipped folder. After you see the full path to the .sh file copied to terminal window prompt, hit Enter.

I followed the instructions

I followed the instructions and got this error.


Traceback (most recent call last):

File "./", line 23, in <module>

from fr0stlib.gui import Fr0stApp

File "/Users/Sam/Desktop/fr0st-1.4-src/fr0stlib/gui/", line 22, in <module>

import imp, os, sys, wx, time, shutil, copy, cPickle as Pickle, itertools, \

ImportError: No module named wx


Im am running OSX 10.7.1


I'm not sure what any of this means. If you know anything or anyone that could help, it would be greatly appreciated.




It is because the wxPython is

It is because the wxPython is not installed by default on 10.7. The fr0st needs it.

You can download it from here:

run the installer and then the fr0st should work as expected.

thanks for the report.  i

thanks for the report.  i believe there is an incompatibility with 10.7 but i don't know the solution yet.  anyone?

not sure what went

not sure what went wrong


Last login: Sun Dec 31 19:00:54 on console

sam-judelsons-macbook:~ Sam$ /Users/Sam/Downloads/fr0st-1-1.4-src/

/Users/Sam/Downloads/fr0st-1-1.4-src/fr0stlib/ Warning: 'with' will become a reserved keyword in Python 2.6

Traceback (most recent call last):

File "/Users/Sam/Downloads/fr0st-1-1.4-src/", line 23, in <module>

from fr0stlib.gui import Fr0stApp

File "/Users/Sam/Downloads/fr0st-1-1.4-src/fr0stlib/", line 876

with open(path, "w") as f:


SyntaxError: invalid syntax

sam-judelsons-macbook:~ Sam$


open a terminal, type "cd X"

open a terminal, type "cd X" where X is the path of the unzipped folder, something like "~/Downloads/fr0st-1.4-src".  press return.  then type "./" and press return.

I have tried this several

I have tried this several times and keep getting the results above. What is going wrong and how can it be fixed?





Hey, I downloaded the

Hey, I downloaded the electric sheep version of Apophysis, how can I increase the complexity of the inbuilt script? I don't know how to code the flam3 stuff, so it would be cool if I could just copy and paste off someone :) Also how do I export it to include the script for the animation?

you should ask on the genetic

you should ask on the genetic design email list.

i need help.

Electric sheep does not come on when my computor sleeps i have to open it on my desk top, log in and click run, and it opens a new window....? is it supose to do that or um open when my computor sleeps....????

it should work like a regular

it should work like a regular screensaver. please find the forum for your computer type (mac, windows, or linux) and provide more details there (your OS version and hardware specs).


thanks for the free software. Wow. You got one guy creating ships and another using widows. Is that legal?

help me please

help me i just started today and i dont know how to make a eletric sheep background

Sorry, I don't understand

Sorry, I don't understand your question.


Thanks for the list of software. I've already found Apophysis for free. Downloaded the torrent from . I looked through your gallery and I must say it is stunning. It is a miracle to creat such pieces. I hope someday I'll be able to create such ships too.

Fr0st or Apophysis?

I am a widows user and i was wondering what the difference between Fr0st and Apophysis was. Is one preferred over the other?

Fr0st is more up-to-date and

Fr0st is more up-to-date and is still developing.

Apophysis is more mature and has more users, but has become stagnant.

Everyone has their own preference. If you try either or both out, please let us know here what you think and if you find any problems.


i dont get it this thing isnt working right. i just want electric sheep, not Frost. Will somebody please tell me what im doing wrong. i just want to download electric sheep

click "download" on the menu

click "download" on the menu at the left, and then follow the instructions for your operating system.

if you have any problems ask on the forum for your computer.

Uploading new source sheep.

Ok people, this project is absolutly fantastic.

But my question is, How can I put new sheep on the server?

I have designed one in Fractal FrOst, used the special script to export, and now what i have to do with exported file mylinear.flame??? I cant find any manual or steps to get my fractals on the sheep server...

Thanks Memphis

join the email list and ask,

join the email list and ask, as instructed above.



Do you use mac pc or linux

Do you use mac pc or linux

how do you know it recorded your vote?

it would be nice to get some kind of visual feedback that it got your button press and sent it in.


No up sheep/down sheep?

The application is supposed to animate either an upsheep (sheep with head up) for a postive vote and vice versa for a negative vote.

re: No up sheep/down sheep?

Found you can vote and had same remark. Then came here and saw someone had posted the same question I had. I do NOT get the heads up or down when I vote with the arrow keys. Leaves me to wonder if my vote has been registered. Just wondering.

You might have turned on

You might have turned on "Direct Draw" mode. You should try turning this off, it should only be necessary for very old graphics card or people with broken drivers.

The next release will show the icons even with this mode.

The head doesn't show up for

The head doesn't show up for me either when I try this on Ubuntu, running it from terminal. And if you try the electricsheep-preferences option, there is no checkbox for a direct draw mode or anything.

Hi guys

Hi I am new here, , thanks a lot for share.


User login