Rendering frames, but no download of sheep?

I am running Windows v2.7b18. I have modified c:\windows\system32\drivers\etc\hosts to redirect r2d7c.sheepserver.net to 74.207.242.239. I will still get the "Error connecting to server, using free one" message (don't care).

Anyway, ES seems to be connected to the correct server because it has successfully rendered at least one frame (sheep_244_1023_1139.png) - the request for doing so must have come from the server.

I have no idea whether this frame was uploaded, and I have not received yet a single sheep from the server?!

Confused,

Michael

 

Date on the file is current

Date on the file is current 9/18/09

 

Deleted it and re-ran and here is what it pulled;

 

<code>

<list gen="244" size="800 592" retry="600">
<sheep id="84" type="0" state="done" time="1249872282" size="829376" rating="0" first="84" last="84" url="http://cdn0.sheepserver.net/gen/244/84/sheep.avi"/>
<sheep id="90" type="0" state="done" time="1249872636" size="1132930" rating="0" first="90" last="90" url="http://cdn0.sheepserver.net/gen/244/90/sheep.avi"/>
<sheep id="92" type="0" state="done" time="1249872690" size="3192742" rating="2" first="92" last="92" url="http://cdn0.sheepserver.net/gen/244/92/sheep.avi"/>
<sheep id="93" type="0" state="done" time="1249874695" size="1021266" rating="0" first="84" last="90" url="http://cdn0.sheepserver.net/gen/244/93/sheep.avi"/>
<sheep id="95" type="0" state="done" time="1249906022" size="1591890" rating="0" first="95" last="95" url="http://cdn0.sheepserver.net/gen/244/95/sheep.avi"/>
<sheep id="97" type="0" state="done" time="1249906161" size="1177334" rating="0" first="90" last="95" url="http://cdn0.sheepserver.net/gen/244/97/sheep.avi"/>
<sheep id="98" type="0" state="done" time="1249906172" size="1222540" rating="0" first="95" last="84" url="http://cdn0.sheepserver.net/gen/244/98/sheep.avi"/>
<sheep id="99" type="0" state="done" time="1249906181" size="1077380" rating="0" first="84" last="95" url="http://cdn0.sheepserver.net/gen/244/99/sheep.avi"/>
<sheep id="100" type="0" state="done" time="1249906190" size="1621320" rating="1" first="92" last="90" url="http://cdn0.sheepserver.net/gen/244/100/sheep.avi"/>
<sheep id="101" type="0" state="done" time="1249906219" size="1726138" rating="0" first="101" last="101" url="http://cdn0.sheepserver.net/gen/244/101/sheep.avi"/>
<sheep id="102" type="0" state="done" time="1249906227" size="2346640" rating="1" first="92" last="101" url="http://cdn0.sheepserver.net/gen/244/102/sheep.avi"/>
<sheep id="103" type="0" state="done" time="1249906238" size="2272704" rating="1" first="101" last="92" url="http://cdn0.sheepserver.net/gen/244/103/sheep.avi"/>
</list>
</code>

that's really bizarre, that

that's really bizarre, that file is about 6 weeks old.  maybe your ISP has a web cache?  what do you get if you download http://v2d7c.sheepserver.net/cgi/list and then unzip the contents?  can you sniff your net traffic and see from where it's downloading that file?

timeout

I get a timeout on that url

keep trying.

keep trying.

success

The other day I had tried off and on for probably 45 minutes. No joy. Today I was able to download the file. I added a ".zip" extension, extracted the list file, added a ".xml" extension, moved the new list.xml into the C:\ProgramData\ElectricSheep\content\xml directory (I'm on Vista). Then I started the screensaver manually and successfully downloaded a bunch of my missing sheep.

The screensaver has been unable to automatically download new sheep since the middle of August. I have been downloading new ones manually. Hopefully this method will help fix problems that others are having.

good list.xml got overwritten with old crap again

OK, this is wierd. I had success with downloading as I indicated but then later on the list.xml got overwritten with a "new" file that had the exact same contents as what was posted before. Sounds like a bug.

aha yes it is... the

aha yes it is... the registration was supposed to have been removed from the client, but it wasn't and unbeknownst to me it was accessing part of the server that was shut down and not being updated!  it should be fixed now.  thanks.

Joy. That did the trick

Joy.

That did the trick - I finally get some sheep and the list.xml seems alright.

Cheers, M

I'll keep an eye on it

Thank you. I'll keep an eye on it and see if it ever happens again.

Still no joy

Still no joy - http://v2d7c.sheepserver.net/cgi/list will create a file of length 1.924 which is neither a valid ZIP file (it does not start with "PK" on the first bytes and WinZip will complain) nor a valid XML file (I know one when I see one)

@rlburns: What kind of magic did you apply to make the beast a valid ZIP file?

@spot: Will the list file be updated automatically by the screen saver after this manipulation or does one then still have to pull it manually, say, once a day?

BTW, rendered 120+ frames by now and still no sheep...

Cheers,

Michael

it's gzip not pkzip.

it's gzip not pkzip.

I also noticed that the file

I also noticed that the file did not seem to be a zip but that's why explained in detail the steps I took. Read my post again and do as I did. It worked on Vista.

I did as you did!

I did as you did but gzip is NOT handled correctly on MY Vista environment - I would not have posted otherwise...

try to follow the directions given

Did you actually try to download one of the URLs given in that file like spot instructed in the post below? If you did, report what happened.

Wow

Ok reading this is a total bummer because now with this change I no longer have any sheep. This sucks. I guess I can go find another screen saver since the port changes bascially will prevent it from ever working at my office.

 

Maybe the client should try 8080 and if it doesnt work fall back to something else....

see below.

see below.

try not filling in your name

try not filling in your name and password.

even if you are connecting our CDN might be maxed out, so you can try a sheep pack.

you may need to regenerate the .cfg file

FYI - if you have previously filled in your name and password, simply blanking that out may not work.  At least, it didn't for me. (Windows, beta 18)  I did that, and it said "not signed in" but still failed to download sheep. I had to delete the .cfg file and then start the client back up, to generate a new cfg without name and pw filled in.

No downloads for unidentified

No downloads for unidentified either

I have rendered 13 frames by now, but I get no sheep back... The packs just provide historical data and can only be regarded as a last resort...

ES runs here 24/24 on a dedicated machine for more than 36 hours by now, how can the CDN be maxed out permanently?

it has a complicated quota

it has a complicated quota system (see www.coralcdn.org).  you might be in a busy area and have gotten unlucky so far, or possibly it just doesn't work in some places or for some people, honestly i can't explain it.  we are going to switch to add in more new different and better hosting as soon as possible.

CoralCDN uses port 8080 I

CoralCDN uses port 8080

I cite from www.coralcdn.org: "Coral does not seem to work for me? How sad! This can be due to a number of reasons. One big reason may be that you are behind some firewall blocking port 8080"

Well, I happen to live behind a firewall blocking port 8080.

The old server (generation 243) was purely port 80-based? (just an assumption, because that worked for me both ways)

If so, any plans to provide a pure port 80 solution again?

50+ frames rendered, but no sheep... snif.

Michael

it's using port 80

it's using port 80 now:

http://wiki.coralcdn.org/wiki.php?n=Main.FAQ#highport

but i'm sure you are right, some issue with coral is blocking the sheep. you can check by looking at the list.xml file (in the xml folder in the sheep root), and trying to download the URLs listed in that file, and seeing what happens.  if you have access to a comand line, see if you can use "curl" with verbose output.

yes generation 243 used a simple server instead of a distributed cache, but we lost that host.  fortunately we have a new one lined up, i'm sure it will work better for you.  watch for the announcement here.

note that "the server" is a euphamism for a complex multi-machine system, which can be partly working and partly reachable and changes over time.

I tried your suggestion of

I tried your suggestion of extracting urls from the list and using curl to try to get them, here is the result.

 

<code>[root@dark ~]# curl -v http://cdn0.sheepserver.net/gen/244/84/sheep.avi
* About to connect() to cdn0.sheepserver.net port 80
*   Trying 69.163.47.15... No route to host
* couldn't connect to host
* Closing connection #0
curl: (7) couldn't connect to host
[root@dark ~]#
</code>

Comes up the same no matter what url I use.

 

Traceroute...

 

[root@dark ~]# traceroute cdn0.sheepserver.net
traceroute to cdn0.sheepserver.net (69.163.47.15), 30 hops max, 40 byte packets
1  happyday.rapidvps.net (208.84.147.82)  0.092 ms  0.044 ms  0.024 ms
2  66.35.95.125 (66.35.95.125)  1.170 ms  1.227 ms  1.272 ms
3  tagg-01-t1-6-0-0-19-0.mtld.twtelecom.net (64.132.248.141)  0.499 ms  2.106 ms  2.085 ms
4  66.192.243.146 (66.192.243.146)  9.390 ms  9.502 ms  9.479 ms
5  po15-0.core01.atl01.atlas.cogentco.com (154.54.5.109)  193.380 ms  193.420 ms *
6  te8-3.mpd02.atl01.atlas.cogentco.com (154.54.5.38)  9.852 ms  9.864 ms  9.874 ms
7  te7-1.ccr01.atl01.atlas.cogentco.com (154.54.28.61)  56.276 ms te2-3.mpd02.ord01.atlas.cogentco.com (154.54.29.82)  29.024 ms te9-1.mpd01.atl01.atlas.cogentco.com (154.54.28.53)  9.972 ms
8  te2-2.ccr02.mci01.atlas.cogentco.com (154.54.25.77)  42.726 ms te7-1.ccr01.ord01.atlas.cogentco.com (154.54.25.177)  29.656 ms te4-2.ccr02.mci01.atlas.cogentco.com (154.54.6.253)  42.665 ms
9  te7-1.mpd01.mci01.atlas.cogentco.com (154.54.24.93)  42.645 ms  43.041 ms  42.697 ms
10  te4-4.mpd01.den01.atlas.cogentco.com (154.54.24.81)  54.063 ms  54.170 ms  54.140 ms
11  te4-2.ccr01.slc01.atlas.cogentco.com (154.54.0.42)  75.397 ms  75.753 ms  75.458 ms
12  te4-2.ccr01.smf01.atlas.cogentco.com (154.54.1.101)  75.403 ms  75.727 ms  75.692 ms
13  te4-1.ccr01.pdx01.atlas.cogentco.com (66.28.4.94)  87.673 ms  87.637 ms  87.722 ms
14  38.100.208.186 (38.100.208.186)  87.647 ms  87.722 ms  87.374 ms
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  38.100.208.186 (38.100.208.186)  300.257 ms !H  300.218 ms !H *

that's weird, that list.xml

that's weird, that list.xml file is old, it should have been updated.  what's the date on it (and the date on your machine?)  what if you delete it and run the screensaver again?  it should download a new one with different URLs....

It just regens with the same

It just regens with the same data. Download attempt produces same result? See post a top of theread, replied in the wrong spot.

my list.xml is exactly the same

I checked my list.xml file and it is exactly the same as what red_eye posted. I also have not been able to download any new sheep while the screen saver is running. I download manually every few days. Interestnig.


User login

Login/Register