Has voting protocol changed ?

I wrote my own electricsheep client a couple of months ago, including the ability to vote for sheep and it was working fine but the voting seems to have stopped working recently.

I used the voting protocol given in the Wiki on Google project hosting.

Having had problems recently trying to get hold of the current source from the Google project hosting (I still can't get hold of anything more recent than b28) I'm wondering if the protocol for voting has changed and either the wiki hasn't been updated or I'm having the same problem as with the code - seeing an old version.

Any help would be appreciated.

no it hasn't changed. what

no it hasn't changed.

what problems do you have with the source?  what happens if you run this command in a new folder: svn checkout http://electricsheep.googlecode.com/svn/trunk/ electricsheep-read-only

Back on my original question,

Back on my original question, based on the wiki documentation my client was sending:

v2d7c.sheepserver.net/cgi/vote?vote=1&u=9E62269138382C49&id=51937&v=LNX_2.7b12

using the UID and version values taken from preferences.xml (I've omitted the http:// prefix to stop this from being formatted as a link).

Having looked at the source code (line 84 in Voting.cpp), I've tried changing this to:

v2d7c.sheepserver.net/cgi/vote.cgi?vote=1&u=9E62269138382C49&id=51937

Both appear to be accepted (i.e. no exception raised) but the rating of the sheep doesn't appear to change.

Hurray hurrah!

Well, this time, it looks like I've got the current version!

("checked out revision 81" on the console and "2.7b33-svn" in the configure.ac file).

I'll have a go at compiling it again (and also have a dig around in the code of my client to find out what's going wrong with the voting :b).

UPDATE: Ho hum. No success with compiling from source :(

In case you're interested, I used the svn checkout command in my /usr/local/src folder to get the source, switched to usr/local/src/electricsheep-read-only/client_generic and ran ./autogen.sh which reported "Warning: autoreconf failed" but successfully ran the preparation steps manually.

I then ran CXXFLAGS="`wx-config --cxxflags`" LDFLAGS="`wx-config --libs all`" ./configure (I tried ./configure on it's own first but got the usual problems with wxWidgets in the make step) and finally ran make which quickly came back with the following error report:

../../Common/Log.cpp: In member function ‘void Base::CLog::Log(const char*, const char*)’:
../../Common/Log.cpp:455: error: ‘strcmp’ was not declared in this scope
../../Common/Log.cpp:491: error: ‘memcpy’ was not declared in this scope
../../Common/Log.cpp:492: error: ‘strcpy’ was not declared in this scope
make[1]: *** [Log.o] Error 1
make[1]: Leaving directory `/usr/local/src/electricsheep-read-only/client_generic/MSVC/SettingsGUI'
make: *** [all-recursive] Error 1

Apart from the regret of not being able to see the new version, I'm not much affected by this. My interest is more in designing sheep at the moment rather than spending time watching them (other than watching mine, of course :b).


User login

Login/Register