electricsheep (mplayer, actually) prevents DPMS timeouts; any _other_ tricks to mitigate the problem?

Electric Shepherds --

I was hoping some of the electricsheep developers might have some enlightened ideas about this.

When I run electricsheep on my Linux machines, even though xset q shows that DPMS is turned on, my monitor never goes to sleep.

I drilled down, and I figured out this happens whenever mplayer (or ffplay) is open and playing a video. mplayer (or ffplay) somehow keeps DPMS counters awake so they never trigger their timeouts.

I did notice that issuing an xset dpms force off after mplayer (or electricsheep) has started keeps the monitor off. So I've rigged a process to run in parallel with electricsheep to mimic DPMS behavior, but it's not perfect.

Is there a way to restore DPMS timeouts?

Thanks --
Ted

Due to bug in mplayer; should be fixed soon

This problem is caused by a bug in mplayer causing it to ignore -nostop-xscreensaver. The simple one-line patch has been presented on the mplayer-dev-eng mailing list and hopefully should be checked into the mplayer distribution soon.

mplayer bug fixed; now need ~/.mplayer/config option

Yesterday, the important mplayer bug was fixed. Now,

mplayer -nostop-xscreensaver

will prevent mplayer from disabling DPMS. Unfortunately, a fix after that will make -stop-xscreensaver the default. Consequently, either this option needs to be added to electricsheep. Alternatively, the line

stop-xscreensaver = no

can be added to the ~/.mplayer/config file so that all instances of mplayer default to not stopping DPMS.


User login